Win 7 startup problem

Discussion in 'PC Technical Talk' started by Robin Faichney, Sep 24, 2012.

  1. Having trouble with a Sony Viao touchscreen all-in-one unit running
    Win 7 Home Premium 64 bit.

    Under normal startup and also safe mode with networking it BSODs every
    time with DEVICE_IRQL etc, STOP D1, ndis.sys

    Intermittently it hangs during safe mode w/o networking startup.

    It has hung during the built-in Win7 memory diagnostic but passed
    memtest86+ (so far have not repeated either).

    Googling suggested a possible prob with the wireless adapter driver
    but un- and reinstalling that made no difference. After using msconfig
    to setup a minimal diagnostic startup, it BSODed as above, presumably
    because the prob is due to a driver, not a service or startup prog.

    Only recent system restore dates are available and the earliest
    doesn't help.

    I'm now approaching the hair-tearing stage and considering a full
    system recovery, hoping I can do backups in safe mode first. Any other
    ideas?
     
    Robin Faichney, Sep 24, 2012
    #1
    1. Advertisements

  2. Robin Faichney

    Graham J Guest

    ndis.sys probably relates to the network card.

    Is it integrated on the motherboard or removeable?

    If the former, try to disable it in the BIOS.

    If the latter, remove it.

    Does the system then work reliably?

    If it doesn't can you boot a disk-based operating system (BartPE,
    Knoppix, or similar) and confirm that the hardware works reliably?

    Whatever, take the hard disk out and connect it into another Windows
    machine (ideally Win 7) and back up all the user's data from it.

    Is the machine under manufacturer's warranty?
     
    Graham J, Sep 24, 2012
    #2
    1. Advertisements

  3. It's integrated but there's nothing about it (and not much else
    either) in BIOS setup. So in safe mode I disabled both wireless and
    ethernet adaptors in Device Manager and that did the trick, allowing a
    normal startup. I then tried enabling the wireless adaptor but got a
    BSOD immediately. I have a feeling that maybe ndis.sys is involved in
    all networking?

    The pc is currently installing Win7 SP1, which had previously been
    downloaded. On another machine I've downloaded the latest drivers for
    both adaptors. If SP1 makes no diff I'll try installing the drivers,
    but I'm not sure whether that will work with the adaptors disabled.
    Haven't tried that yet though I'm a bit concerned there might also be
    a separate issue, causing the occassional hang during safe mode boot
    and the Win7 memory diagnostic. However, it ran memtest86 happily
    overnight.
    I'll certainly backup the data before doing a system recovery.
    No
     
    Robin Faichney, Sep 25, 2012
    #3
  4. Robin Faichney

    Ian Guest

    A quick solution may be to buy an external wireless adaptor, and
    permanently disable the internal one.
     
    Ian, Sep 25, 2012
    #4
  5. Thanks (and to Graham) but the driver installation fixed it. Or fixed
    the main issue anyway -- still don't quite understand the pattern of
    symptoms but it's been behaving perfectly for a couple of hours so
    back it goes!
     
    Robin Faichney, Sep 25, 2012
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.