What do you think, will connecting a ST-225 work (part 2)

Discussion in 'DIY Computers' started by Rich, Nov 7, 2009.

  1. Rich

    Rich Guest

    Some people were curious about the outcome of my efforts to run a vintage
    ST-225 HD on my relatively modern (1998) motherboard (MS-6119), with an 8
    bit controller card (WD1002A0WX1).

    I'm working totally with DOS. All IDE set to "not intalled" in my system
    BIOS. Floppy disk connected.

    The procedure to follow is:

    1 Low level format the drive using the programme that comes with the
    controller card. This is effected by runing DEBUG, and at the prompt:
    G=C800:5.

    2 Partition the drive using FDISK

    3 Hi level format the drive using FORMAT

    Report:

    I can low level format the drive, but I cannot create a partition with
    FDISK.

    This is the point I think where some (not all) are prevented from installing
    an old ST-225.

    Running FDISK produces "Error Reading Fixed Disk". Running FDISK/STATUS
    produces:

    DISK DRV MBYTES FREE USAGE

    1 20 20 %

    When my PC starts up, the drive is interrogated, because I see the red LED
    on the drive itself flash a few times.

    If I enable IDE0 to boot from my regular hard drive, when the controller
    card is in, the system promts me to put in a floppy boot disk. When the card
    is out, the system boots from my regular C:

    I believe the ST-225 is using BIOS in the controller card.

    I think that in some cases the problem can be caused by system BIOS not
    getting along with the controller BIOS.

    I don't know what further diagnosis or procedure I could do to psyche
    out the problem. There may be no fix I realise, not even with a 16 bit
    controller card.

    Motherboard: http://artofhacking.com/th99/m/M-O/34347.htm

    Controller card: http://artofhacking.com/th99/c/U-Z/20217.htm

    P.S. I don't know if using FIXMBR would help. Probably not.
     
    Rich, Nov 7, 2009
    #1
    1. Advertisements

  2. Rich

    Rich Guest

    Hi, this could be a right nightmare and I may fail, but actually, I'm
    learning about PCs doing this, and enjoying attempting this crazy thing. :c)

    I was completely gobsmacked when FDISK could not read or write to the drive.
    Because of course, I'd got the PC to low-level format. It *looked like* then
    that: a) the ST-225 is working, b) the ISA controller card is working C)
    system is all working fine.

    I know that all that FDISK really does is lay down Standard MBR on the boot
    sector of a disk.

    My PC obviously knows there is "a disk" connected to the system. And it does
    so by relying on BIOS on the controller card, not my regular AMI BIOS. What
    is interesting is that FDISK /STATUS does return some data about the disk.

    DISK DRV MBYTES FREE USAGE

    1 20 20 %

    http://artofhacking.com/th99/c/U-Z/20217.htm

    Okay, card settings at presnt:

    W3: closed (BIOS enabled)

    W4: 2-3 (i/o 320h)

    W5: 1-2 (hardwired) ROM size 32K 64K

    W6: open (correct because my HD is just 4 head)

    W7: 1-2 (hardwired) (Interrupt IRQ5)

    W8: 2-3 (Single Controller setting, primary contoller)

    s1/jumper7: open (IRQ5)

    s1/jumper8: (AT mode enabled)


    So, I'm IRQ5 and I've not tried to change s1/jumper7.

    As to DMA: The DMA channels are 0, 3, 5, 6, 7 and all set to Pnp. The option
    is Pnp or ISA / EISA

    As to IRQ I see IRQ 3, 4, 5, 7, 9 and these are all set to PCI/Pnp. Options
    are PCI/Pnp or ISA / EISA.

    The HD controller card is in IDE slot 1.

    I've never had anything in an ISA slot bfore, neither an old 8 bit card.

    As to DOS verion: I've taken DOS from Windows98 First Eition, so it's
    version 7.1. Any DOS programs I've coped onto a floppy I'm taking from
    Windows98.
     
    Rich, Nov 8, 2009
    #2
    1. Advertisements

  3. Well done. What was it in the end, you or the card?
    Hmm. No errors from a c800:5 format? Did you hear the drive tick
    regularly as the format progressed? Were you asked for an interleave
    value?
    must be, if you see the drive light flash as the card initialises.
    I doubt it very much. Have you tried the other drive you say you had?
     
    Mike Tomlinson, Nov 8, 2009
    #3
  4. Do you know whether that's defined? I've seen zeros, 0xFF, 0xF6 and
    probably a myriad others that I've forgotten.

    Wonder whether a Linux LiveCD would recognise the XT controller card the
    OP has? :)
     
    Mike Tomlinson, Nov 8, 2009
    #4
  5. Rich

    Rich Guest

    Errata: ISA slot 1.
     
    Rich, Nov 8, 2009
    #5
  6. Rich

    Rich Guest

    Interestingly, I have a version on CD of Vector Linux v5.8 solo. Don't know
    if installing that would have mileage.
     
    Rich, Nov 8, 2009
    #6
  7. Rich

    Rich Guest

    Yep, It sort of makes a ratchety sound (followed by a small beep)and
    repeats. Goes on for hours. Interleave value 3. I did the simplified
    low-level format option. I even did a dynamic low-level format with
    settings:

    ccc h rrr ppp ee o
    615 4 621 621 11 5

    I should really rely on the simplified I think.

    Yes, a bit. I was trying not to low level-format this, because I was wanting
    to see any data on it.

    DOS utility MBRTool ought to read the first sector of the disk, but it only
    shows ??????????... Meaning, it never accessed the disk - I bet.

    I wonder if it's BIOS DMA thing. Or IRQ thing.
     
    Rich, Nov 8, 2009
    #7
  8. Good, that's it finding track 0, then track 612 and going back during
    its initialisation routine. It should do it just once, when the drive
    is powered up.
    Not good. May mean it can't find track 0, or you've set the interleave
    too low for the drive to cope.
    Too low. Try 6 for an XT-class controller.
    What's o? Maybe interleave...
    OK, fair enough.

    And you still haven't told us what you did to get the shebang working in
    the first place... spread your knowledge!
     
    Mike Tomlinson, Nov 8, 2009
    #8
  9. I'm not sure the card supports DMA, so this should not matter. Reserve
    DMA3 for ISA/EISA anyway, as JJ recommends - it certainly won't hurt.
    You should definitely set IRQ5 to ISA/EISA. Again this probably won't
    make a difference, since 5 is generally unused by the mobo anyway.

    If you haven't already, I'd sugges turning off the serial and parallel
    ports in the BIOS, in case they decide to reserve strange DMA/IRQs.

    The ISA slot you have it in will not matter - all ISA slots are
    created equal, which is why you had to hard-code the bloody IRQ and
    DMA all the time.

    Cheers - Jaimie
     
    Jaimie Vandenbergh, Nov 8, 2009
    #9
  10. Rich

    Rich Guest


    ----
    After 5 hours I get:

    "Format Successful
    System will now restart
    Insert DOS diskette in drive A:
    Press any key when ready."


    The ST-225, I believe, is regarded as a "standard" 20 MB HD (615 cylinders,
    4 heads). On simplified formatting (which I think may be the best choice)
    the interleave is 3 and it's recommended. These instructions were made mid
    1980's or therabouts. I've done the simplified formating:


    -----
    http://www.uncreativelabs.net/textfiles/drives/20MEG.FMT


    Re: dynamic formatting:

    "The Super BIOS program displays the initiate dynamic configuration
    message:Key in disk characteristics as follows:

    ccc h rrr ppp ee o where:

    ccc = total number of cylinders (1-4 digits)

    h = number of heads (1-2 digits)

    rrr = starting reduced write current cylinder (1-4 digits)

    ppp = write precomp cylinder (1-4 digits)

    ee = max correctable error burst length (1-2 digits) range
    = 5 to 11 bits, default = 11 bits

    o = CBB option byte, step rate select (1 hex digit) range
    = 0 to 7, default = 5 refer to controller and drive
    specification for step rates.

    Enter each value separated by a space and follow the complete entry
    with a RETURN. Enter physical cylinder values.

    Example for ST 251: 820 6 821 410 11 5 (CR)

    note st-225 620 4 621 621 11 s (cr)"

    I think there is errata with the note above, for ST-225 probably should be:

    615 4 621 621 11 5
    -----

    My original problem was simply a video card writing code all over C800:0000
    area, and prevented DEBUG -G=C800:5 from working. Now I can low-level
    format, but cannot get any read or write so cannot get FDISK to write the
    standard MBR.
     
    Rich, Nov 8, 2009
    #10
  11. Rich

    Rich Guest

    I sometimes see folks talking about setting IDE0 to type 2. Mine is a type 2
    drive. The controller card is ST-412 type. There is I think some relation in
    type ST-412 controller cards to IDE, but I'm not sure whether having IDE0
    set to type 2 can have any relavence work. I'm thinking not because, well,
    I'm not suppossed, I guess, to have an IDE card or controller card
    installed. But there is relationship between IDE and ST-412.

    I'll make adjustments suggested.
     
    Rich, Nov 8, 2009
    #11
  12. writes
    ]
    There is, but only in the software interface*. ST-412, a hardware
    interface definition, evolved from ST-506 (they're essentially the same
    thing.) If you want a similar example, look at SASI and SCSI.

    http://en.wikipedia.org/wiki/ST-412

    * The software interface to the controller is referred to as
    "1700-compatible" or similar (I've googled for the precise spec but
    can't find it, my google-fu's weak tonight.) This is in turn used by
    BIOS interrupt 13h, which BIOS uses to boot.

    IDE disks have to adhere to this spec if it is desired to boot from
    them. Once specific OS-level drivers have been loaded it's up to those
    drivers what to do with data presented to them. This is how modern
    versions of Windows boot: they load using the basic BIOS interrupt, then
    load their own drivers to load the rest of the OS using (often faster)
    drivers more suited to the specific disk controller in use.
     
    Mike Tomlinson, Nov 8, 2009
    #12
  13. Too long. It should take ~10 - 15 mins or so, no more.
    Yes. Different sources will give you different results. My HD bible
    dating back to March 1995 says

    cap 21M
    cyl 615
    hd 4
    spt 17
    wpc 300
    pah. by newbies.
    Hell, I remember all that.

    They are very very wrong suggesting interleave 3 for an XT controller.
    If it runs at all, it'll run like a stunned slug.
    agreed, stick with that.
    Stick with 5. Any other value may cause the controller to attempt to
    step the drive heads too fast, leading to problems.
    620 cyls is too many. That'll cause the sort of problems you have been
    seeing. I recommend the following:

    612 4 612 612 11 5
    hmm. 621 is beyond the max cylinder the drive can access. For ex, the
    parking cylinder is spec'd as 621, that'll just cause the drive to
    repeatedly bang the head arms into the central spindle, possibly with
    damage.
    You're almost there, don't worry.
     
    Mike Tomlinson, Nov 8, 2009
    #13
  14. Rich

    Rich Guest

    Wow! Thing is, after the process, I do get the proper message for succesful
    low-level format.
    I'm running the old controller on "AT mode enabled". Because my system is
    AT. But the WD1002A-WX1 is essentially an XT controller I guess.
    I thought the cylinders in the ST-225 handbook were the nature of a
    parameter of the ST-225, of 512 cylinders, and that is what you always put
    in whenever specifying a cylinders value in HD install programs. Seems not.
    :c)


    This is why I changed the cylinders from 620 to 615.

    Weird why the format takes sop long. But then again I have a very old HD,
    with a very old (but compatible) HD controller, in a mobo made about 14
    years after these items.

    I wonder if I need IBM PC DOS 3.0. Or some other verion of DOS.
     
    Rich, Nov 8, 2009
    #14
  15. Rich

    Rich Guest

    Hi. I tried yesterday to contact, but email bounced.

    My email is:




    Please remove capital letters (GARBAGEBIT). There is un underscore after y
    in hobby.

    Rich
     
    Rich, Nov 9, 2009
    #15
  16. Rich

    Rich Guest

    Hi. I tried yesterday to contact, but email bounced.

    My email is:




    Please remove capital letters (GARBAGEBIT). There is an underscore after y
    in "hobby".

    Rich
     
    Rich, Nov 9, 2009
    #16
  17. Rich

    Rich Guest

    Hi. I tried yesterday to contact, but email bounced.

    My email is:




    Please remove capital letters (GARBAGEBIT). There is an underscore after y
    in "hobby".

    Rich
     
    Rich, Nov 9, 2009
    #17
  18. Rich

    Rich Guest

    I don't even know why a card for an XT is not (usually) compatible with an
    AT machine. :c)

    Some questions (for everbody):

    Is it about right that it takes 5 hours to physically format the 20 meg
    drive? I mean, it is setting the disk geometry.

    Can you choose any value for cylinders, or do you have to go with 615 (the
    handbook value)?

    Anyway, because the red LED lights up on the drive on (DOS) startup, most, I
    think, would have bet the drive is readable and writeable. But FDISK just
    won't show it's menu, because there is no drive accessibility, all FDISK
    will do is show there is a 20 meg disk installed, when the STATUS swith is
    used. Clearly my system BIOS hands over (in some way) to the controller card
    BIOS in order that the HD can be accessed. But I know that this arrangement
    of outboard controller card, is not the modern arrangement. But I do also
    know that folks have used this arrangement right up to Pentium 3. But,
    coming up short at FDISK is, I think the thing that some others (like me)
    get stuck on.

    It's no big thing, I'm just messing about. But I wish I could crack this, by
    and by. :c) But, nothing has worked yet.
     
    Rich, Nov 9, 2009
    #18
  19. No. From rusty memory, it should be between 10 minutes and half an
    hour.

    Excessive time would normally mean (a) that your interleave is too
    small - so rather than being able to jump from one cylinder to the
    next and catch the start of the new cylinder, it's missing and having
    to take an entire extra revolution before it gets going.

    Or (b) that the disk is damaged and going through many retries to seek
    or verify, but you'd be able to tell by the different clicky noises
    the dodgy bits would make.

    Cheers - Jaimie
     
    Jaimie Vandenbergh, Nov 9, 2009
    #19
  20. Rich

    Rich Guest

    Can I just ask about my system BIOS.

    Under a normal situation there would be an IDE HD fitted, and it would be
    accessed through one of the IDE controllers on my motherboard. My systems
    CMOS (BIOS chip) needs to know the disk parameters. You tell CMOS these
    parameters when you have your IDE enabled and you either have AUTO set, or
    you specify a drive type, or you enter the HD details yourself. In this
    situation you are enabling the PC to read and write to the drive through, of
    course, the controller which happens to be integrated with the motherboard.

    My situation at the moment is that IDE is disabled and the HD contoller sits
    in an IDE slot.

    Now, in this situation you disable IDE controllers. But, despite that, I do
    read in places, about telling BIOS about the drive parameters. That is
    setting CMOS with the parameters of the drive. That confuses me a bit,
    because I'm thinking, if you disable IDE in BIOS, then how can you set any
    drive parameters. Yet, this is exactly what is being talked about here:

    http://www.vintage-computer.com/vcforum/archive/index.php/t-4352.html

    Now, I have a type 2 drive, and I can choose that in my system BIOS.

    There are two kinds of disabling options: You can set IDEO, IDE1, IDE2, IDE3
    to "not installed" or you can simply disable IDE elsewhere in the BIOS menu.

    You must be able to disable IDE, yet still set IDE0 to type 2?

    I am confused here because how can you set IDE0 to type 2, if you disable
    IDE0.?

    So, I don't really understand that article on vintage computer forum. Can
    anyone please tell me what's the scoop? Thanks.
     
    Rich, Nov 9, 2009
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.