VPN tunnel is up but can't access resources

Discussion in 'Networking and Internet' started by Core, Apr 3, 2012.

  1. Core

    Core in pounce mode Moderator

    Joined:
    Jun 30, 2003
    Messages:
    1,557
    Likes Received:
    24
    Location:
    Akaa, Finland
    (X-posted here from W7forums)

    I am trying to set up a VPN connection between two offices. Both are using a Cisco RVS4000 router. A tunnel is set up between the external IP addresses of these routers. The tunnel is "up" and I can access the admin interfaces of both routers from both locations by using their internal IPs (192.168.1.1 and 192.168.2.1).

    However, I can't use/share any of the resources, like workstations, data, peripherals... I've tried turning off the router firewall, and God knows what else, but nothing seems to help...

    I have set up a folder to be shared for Everyone on one of the machines on the "other" network. I have tried adding it as a network resource (mapped to a drive letter) both via IP and workstation name, both result in Windows thinking for a while and then reporting it cannot use (the Windows is in Finnish so the translation may not be exact) the target and to check spelling. Error code 0x80070035.

    Initially, DHCP settings on both networks/routers had the same subnet mask for the networks (255.255.255.0). In case that's a problem I've changed it for the second router to be 255.255.255.128. I didn't do this before because I thought 192.168.1.x/192.168.2.x was enough.

    While I can use a workstation on network1 to ping the IP of a network2 workstation successfully, I can't ping a network2 workstation from the network1 router! The problem, based on my research, may be with the routing tables, but I can't seem to be able to figure out what I need to add into the routing tables via the Static Route page. No matter what I add, it reports either IP/subnet mask conflict, or network unreachable. I can't add anything to the routing table.

    Here are the current routing tables for network1 and network2, respectively (external IPs w/x/y/z'd out because I'm paranoid):

    Network1 - router 192.168.1.1 - subnet 255.255.255.0:
    Destination LAN IP / Subnet Mask / Gateway / Interface
    192.168.1.0 / 255.255.255.0 / 192.168.1.1 / LAN
    192.168.1.0 / 255.255.255.0 / 0.0.0.0 / LAN
    XX.XXX.XXX.0 / 255.255.248.0 / YY.YYY.YYY.YYY / WAN
    XX.XXX.XXX.0 / 255.255.248.0 / 0.0.0.0 / WAN
    239.0.0.0 / 255.0.0.0 / 0.0.0.0 / LAN
    0.0.0.0 / 0.0.0.0 / XX.XXX.XXX.1 / WAN

    Network2 - router 192.168.2.1 - subnet 255.255.255.128:
    Destination LAN IP / Subnet Mask / Gateway / Interface
    192.168.2.0 / 255.255.255.128 / 192.168.2.1 / LAN
    192.168.2.0 / 255.255.255.128 / 0.0.0.0 / LAN
    ZZ.ZZZ.ZZ.0 / 255.255.252.0 / WW.WWW.WW.WWW / WAN
    ZZ.ZZZ.ZZ.0 / 255.255.252.0 / 0.0.0.0 / WAN
    239.0.0.0 / 255.0.0.0 / 0.0.0.0 / LAN
    0.0.0.0 / 0.0.0.0 / ZZ.ZZZ.ZZ.1 / WAN

    Something is probably missing from these tables but I don't know what. In order to add something to the routing table I need to input a destination IP address, a subnet mask, a gateway, and a hop count. I have tried lots of combinations but to no avail...
     
    Core, Apr 3, 2012
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.