VIA AC97 driver install problems

Discussion in 'PC Hardware' started by Slade, Nov 4, 2003.

  1. Slade

    Slade Guest

    Hi there I have a VIA AC97 integrated audio chipset. I was trying to upgrade
    the drivers to the newer ones from via but after restarting my computer the
    add new hardware wizard came up and looked for the drivers for my VIA AC97.
    So I went through the setup using the hardware wizard. After that was done
    the windows 98 setup (updating system settings...) window started loading
    and got I would say about 80 percent done and then just stopped moving. The
    computer worked fine but after 5 minutes I hit ctrl alt del and ended the
    windows setup. I was able to run windows normally but now with no sound. So
    I tried uninstalling the audio drivers, and reinstalling the older ones, I
    then got a message "Via AC97 Chipset is not enabled on this system! Please
    enable it in the bios then run this set up again." I checked my bios
    settings Legacy Audio is enabled, and Sound Blaster is enabled too. I also
    checked my OnChip Sound and it is set to auto. So I am stuck how do I get my
    sound back any ideas?

    S
     
    Slade, Nov 4, 2003
    #1
    1. Advertisements

  2. Slade

    Jan Alter Guest

    Hi,
    First thing I'd try is restoring the registry to pre-no sound condition.
    Shut down or start from a DOS prompt. Type scangreg /restore .
    Win98 keeps the last 5 registries that it backed up. Hopefully it's been
    doing its job and if you're posting this problem soon enough since it
    happened you'll have something to choose. Be aware that if you've made any
    other system changes those will be affected as well to the state the
    computer was in to that date.
     
    Jan Alter, Nov 4, 2003
    #2
    1. Advertisements

  3. Slade

    Khuli Guest

    I would also try disabling the onboard sound in the bios, then
    removing all sound drivers & rebooting.
    Then enable onboard sound again.

    It is worth checking that you have no conflicting IRQs as well.
     
    Khuli, Nov 4, 2003
    #3
  4. Slade

    Slade Guest

    I thought of that didn't include it in my post though I should have but the
    last 5 registries were with no sound I am sorry to say that this problem has
    been with me for some time now I just didn't care to fool with it till just
    recently.
     
    Slade, Nov 5, 2003
    #4
  5. Slade

    Slade Guest

    hmm I'll give that a try but how do I know I have deleted all the sound
    drivers? OR are you just talking about removeing them via the device
    manager. I think I'll try that and see what happens.
     
    Slade, Nov 5, 2003
    #5
  6. Slade

    Gene Puhl Guest

    GO into device manager and remove the device and re-boot. If the device isn't
    faulty, it will be re-detected and Windows will look for the drivers. Have
    the desired drivers handy and point windows to them.
     
    Gene Puhl, Nov 5, 2003
    #6
  7. Slade

    Slade Guest

    ok I have deleted the audio drivers from the device manager, and re-booted.
    Now I am just about positive I have downloaded the correct drivers for my
    chipset. I went to the via website and downloaded the combo drivers. I guess
    they are like a generic driver for a few types of chipsets. But once windows
    was done configuring I still had no sound. So I deleted the drivers from the
    device manager and re booted. This time I used the drives that windows had
    pre installed now I have partial sound for like midi files, but not mp3, or
    mpeg files. Is that progress?
     
    Slade, Nov 5, 2003
    #7
  8. Slade

    Gene Puhl Guest

    No, you have to delete the "device", ie, the sound card, so click on the
    device (sound card, it's under the "sound, video and game controllers"root
    group) in device manager and click remove. Don't worry about the drivers,
    this seems to be where you're getting confused.
    When the device is removed, restart Windows and the device will be re-
    detected and you will be prompted for drivers, point Windows to the location
    of the drivers you want to use. If everything works ok, re-boot and the sound
    card should work.
     
    Gene Puhl, Nov 6, 2003
    #8
  9. Slade

    Slade Guest

    Actually that is what I did initially, before I posted to the group. I went
    to the device manager and deleted all entries under "Sound, video and game
    controllers" the two entries were in from top to bottom, Gameport Joystick,
    and VIA PCI Audio Controller (WDM). It seems that this is one of the many
    problems that no one has had any luck solving I see that similar posts were
    left unsolved, I'll keep trying because I don't think that reformatting the
    HDD is the answer to every little problem but if you have any more ideas I
    would be happy to hear them, and give them a shot.
     
    Slade, Nov 7, 2003
    #9
  10. Slade

    wws Guest

    Try disable soundblaster in bios.
    My epox 8kta+ doesn't use it.
     
    wws, Nov 7, 2003
    #10
  11. Slade

    Slade Guest

    tried that didn't work lol. Ok guys and gals answer me this the motherboard
    doesn't have a label on the front or back of it and I can't find the
    documentation. But if I were to call up the person I got it from and ask
    them, what the name and model number was would that help me at all? I know
    the model number from off the chip is TV82c686a. Would knowing what
    motherboard help me at all or should I not waist my time?
     
    Slade, Nov 8, 2003
    #11
  12. Slade

    wws Guest

    Use aida32,may id your system.
     
    wws, Nov 8, 2003
    #12
  13. Slade

    kony Guest

    That's the point Alien Zord was getting at in the beginning of the
    thread, you need positive ID of the board if you can't otherwise ID
    the sound solution, to lead you to it.

    There should also be a BIOS ID string displayed during POST, that is
    also potentially leading you to the motherboard make/model. AIDA32
    or Sisoft Sandra should both be able to read the BIOS ID too, though
    Google searches for the specific string are the most definitive.

    Also you haven't told us if it was really necessary to use, update to
    another driver originally, if you had a specific need or if you'd be
    agreeable to *any* old driver that works.


    Dave
     
    kony, Nov 8, 2003
    #13
  14. Slade

    Slade Guest

    Ok, ok calm down it's just a sound problem not the end of the world. I'm
    sorry I wasn't able to ID my mother board till now but no one even indicated
    that there may even bee a program that could ID my mother board till wws
    (the post b4 yours) said something about AIDA32.

    Now as for the reason for trying to install the sound drivers I thought I
    had made it clear but I guess I didn't, so let me explain. I was running the
    generic drivers that came preinstalled with the win98 package. But I
    happened on the disk of drivers that I got when I purchased this computer.
    Since there was only one set of drivers on the cd (Via Audio drivers) I
    thought that for the same of compatibility I would install the drivers that
    were meant for the type of hardware I had. But as it turns out I guess the
    person that burnt the drivers gave me the wrong ones or were damaged in some
    manner. So after re-booting I had no sound. So I deleted the drivers and
    tried re installing the ones that I had originally had (the ones that were
    in the system32 folder). That didn't work. I have tried everything from
    restoring old registries, to deleting all the via audio drivers from safe
    mode, to installing them manually from dos with no luck. So while I am not
    entirely sure how this will help you guys get me all set up here is what
    AIDA32 told me I had thanks to wws, and kony for telling me about this neat
    little program.

    Motherboard Properties
    Motherboard ID 08/07/2001-694X-686B-6A6LJB09C-00
    Motherboard Name Biostar M6VCF

    Chipset Bus Properties
    Bus Type PCI
    Bus Width 32-bit
    Real Clock 33 MHz
    Effective Clock 33 MHz
    Bandwidth 133 MB/s

    Motherboard Physical Info
    CPU Sockets/Slots 1
    Expansion Slots 2 PCI, 1 AGP, 1 AMR
    RAM Slots 3 DIMM
    Integrated Devices Audio
    Form Factor Micro ATX
    Motherboard Size 210 mm x 240 mm
    Motherboard Chipset ApolloPro133A

    Motherboard Manufacturer
    Company Name Biostar Group
    Product Information http://www.biostar.com.tw/products/mainboard/index.php3
    BIOS Download http://www.biostar.com.tw/support/bios/index.php3
     
    Slade, Nov 8, 2003
    #14
  15. Slade

    kony Guest

    kony, Nov 8, 2003
    #15
  16. Slade

    Slade Guest

    I tried the links that you sniped which led me to the link that you pasted
    in, and guess what it didn't work. FYI. So I am going to try a few more
    things. First I do have win98SE, but the driver program for win98se, xp and
    all the rest said "Invalid operating system parameters, or this Installer
    doesn't support this operating system" So I hit ok and tried the win9x
    drivers which installed but I hear nothing. Thinking I was crazy I checked
    all my audio connections again for like the 12th time and everything was
    fine there just so you know I am not entirely stupid. So now I will remove
    all the drivers, go to safe mode make sure I got all the audio drivers
    removed and re install the win98se and see if it will continue the install.
    If no I'll install the win 9x again and see what happens.
     
    Slade, Nov 9, 2003
    #16
  17. Slade

    Slade Guest

    well thanks to everyone for trying I have decided to just forget, the
    computer is a little on the old side I'll just buy a new one next year. I
    guess it's one of those unsolvable problems. Thanks again for trying.
     
    Slade, Nov 10, 2003
    #17
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.