SATA HDD USB refuses to work after virus scan

Discussion in 'PC Hardware' started by emekadavid, Jul 8, 2013.

  1. emekadavid

    emekadavid Guest

    I use a SATA combo HDD usb drive as external drive for saving my files. after a thorough virus scan, the first time ever, i was asked to delete an infected file. after shutting down and booting my system hours later, i discovered the system refuses to recognise the HDD usb. it keeps reinstalling itself. what could possibly be the problem? tia
     
    emekadavid, Jul 8, 2013
    #1
    1. Advertisements

  2. emekadavid

    emekadavid Guest

    i do need help fast. all my files are in it. i have no replacement either.
     
    emekadavid, Jul 8, 2013
    #2
    1. Advertisements

  3. emekadavid

    Paul Guest

    There is a small possibility the controller chip inside is made
    by "Cypress" and the configuration information got erased.
    (Google "cypress at2lp rc42" for more info.)

    That happened to my external USB hard drive, and it no longer
    showed up as a USB mass storage device, after I used Seagate Seatools
    for Windows on it.

    You will need to at least open the enclosure and verify it is Cypress.
    If it isn't Cypress, then the explanation likely would not be correct.

    There is a procedure and a tool available, to fix it. It basically
    means reloading the configuration information.

    You could also verify this, with UVCView, look at the configuration
    the device presents, and notice it no longer claims to be a
    storage device. USB has standard "Classes" and there is a class code
    for USB mass storage.

    You can pull the hard drive from the enclosure, and connect it to
    a SATA equipped computer, to get to the files. The files are not
    lost. Just the enclosure chip is affected. That's the theory.

    If the virus scan overwrite the MBR on the hard drive, the enclosure
    would still show up in Device Manager properly, but Disk Management would
    show no valid partitions on it. So that's another thing you can verify,
    that this isn't a problem with the MBR. If the enclosure just won't show
    up at all, it's more likely to be a Cypress problem.

    Your hard drive could also have taken an inopportune time to fail, which
    would be another explanation. But then, that wouldn't align quite as well
    as a theory, versus the configuration data getting overwritten.

    There are many possibilities, which is why it's important to note the
    exact symptoms, whether anything shows up in Device Manager, whether
    UVCView sees anything, or if Device Manager is properly populated,
    whether Disk Management shows evidence the partition table is gone.

    *******

    And if you really "need help fast", remove the hard drive and connect
    the hard drive to a SATA computer. That will tell you your files are safe.
    The files should be immediately visible.

    Paul
     
    Paul, Jul 8, 2013
    #3
  4. emekadavid

    Flasherly Guest

    On Mon, 8 Jul 2013 01:27:09 -0700 (PDT), emekadavid

    i do need help fast. all my files are in it. i have no replacement
    either.
    -

    There's a little utility I was looking at on a site dedicated to
    standalone, soometimes called portable, programs installs, one of
    which makes a USB flash drive bootable. Never personally ran it,
    although my virus scan is surely a standalone, and I'm sure at least a
    million would, but generally I keep handy my boot from my DVDs I've
    replaced in triplicate for the very same reason, that there's
    undeniably nothing better than fast boot to get to all my files.
     
    Flasherly, Jul 8, 2013
    #4
  5. WHAT virus scan gave you this problem?
     
    John B. Smith, Jul 8, 2013
    #5
  6. emekadavid

    emekadavid Guest

    I have avast!, the free edition, and IObit malware remover. I do both scansconsecutively, but only on the c: but yesterday decided just to try it on the external hdd usb drive and now this! At least, from flasherly's explanation, I'll have to think of opening the enclosure because the system recognises the hdd as usb mass storage device on port 2, both with device managerand uvcview.
    thanks
     
    emekadavid, Jul 8, 2013
    #6
  7. emekadavid

    Flasherly Guest

    On Mon, 8 Jul 2013 05:53:38 -0700 (PDT), emekadavid
    and IObit malware remover. I do both scans consecutively, but only on
    the c: but yesterday decided just to try it on the external hdd usb
    drive and now this! At least, from flasherly's explanation, I'll have
    to think of opening the enclosure because the system recognises the
    hdd as usb mass storage device on port 2, both with device manager and
    uvcview.
    -
    System support for storage devices is a matter of connection cables
    and nothing more. There's no "opening" involved other than what is
    required to connect those cables. Beyond which, it's -ALL- software
    manipulatives, including laying down resources for a valid system boot
    sequence.

    Virus scans, although a valid point at times, (as I mentioned I do
    occasional use mine - a, the only, SourceForge freeware virus scanner
    I'm at least aware of --ie. ClamWin), is as well a huge, huge industry
    of profiteering blood-suckers, who promote and feed off the mass fears
    of marginal and incompetent PC operators, most and by in large,
    incapable of protecting themselves, much less assembling either PC
    hardware or a supportive software infrastructure.

    Hence - do witness the rise of a sustained resource from paid
    subscription-based cloud services, wholly-contained although promoted
    for and alonside a faltering PC platform, on but a carrier for
    handheld devices to serve, for a "dumbed-down" generation of people
    since to have realized, progressing from their holy talisman against
    PC technology --pronounced as obfusification-- to smart telelphones to
    supply such liimtations as constitute their want.
     
    Flasherly, Jul 8, 2013
    #7
  8. emekadavid

    emekadavid Guest

    Thanks flasherly, but if i do not solve this problem, i have no heck how to get the data back and you know how much inconvenience it would cost me? that is why i appreciate contributions on this forum and contributors.
    I followed through with your instructions.
    Device manager registers it and uvcview also as a usb storage device.
    disk management recognises the external hdd as disk 1, removable (G:).
    the product is a fujitsu, model no: mht2060ah pl; id:yttn. it has a 2005-6 year dating on it but i can assure you it's not a hardware malfunction.
    so, any suggestions how to go about making the laptop see the partitions rather than just recognise it's existence?
    thanks
     
    emekadavid, Jul 8, 2013
    #8
  9. emekadavid

    Paul Guest

    If the drive is present in Disk Management, you can try TestDisk
    for Windows.

    Do *not* immediately jump on the results. When TestDisk computes
    a replacement MBR (master boot record and primary partition table),
    sometimes it picks up an old partition which is invalid. You have
    to be very careful, before accepting the information it has gathered.
    But that tool can show you, your files are safe. There is a
    preview capability, where it can list the files at the top level.

    http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

    Here, TestDisk shows the files on a partition.

    http://www.cgsecurity.org/mw/images/List_files.gif

    If it was my drive, I would make a sector-by-sector copy
    of it, before applying any repair-in-place tools like TestDisk.
    But that's just me. Safety first.

    Paul
     
    Paul, Jul 8, 2013
    #9
  10. emekadavid

    Flasherly Guest

    On Mon, 8 Jul 2013 06:42:12 -0700 (PDT), emekadavid

    How much money is $19 on ebay for the going cost of inconvenience.
    http://www.ebay.com/ctg/Fujitsu-60-GB-Internal-5400-RPM-2-5-MHT2060AH-Hard-Drive-/69754105

    OK. But, but... It's a glass platter and it's a fluid drive.
    http://reviews.cnet.com/internal-hard-drives/fujitsu-mobile-mht2060ah-hard/4507-9998_7-30636429.html

    That's worth something: forsure, it's shown on ebay not for an
    external drive, (evidently, you've got one of those a manufacturer has
    stuck into a plastic enclosure for calling it an external drive), and
    you're also on a laptop, along with a flashstick plugged into the USB
    port.

    No different than any other computer, except for laptops that can be
    somewhat more delicate and with less latitude for forgiving.

    Let's try and make it simple. Real simple.
    http://www.softpedia.com/get/System...ASEUS-Data-Recovery-Wizard-Free-Edition.shtml

    That's the data, hopefully, along with some place other than the
    Fujitsu, temporarily to store My Data, until My Data is placed again
    where My Data likes to reside.

    The other stuff, what Winderz 'keeps doing to [attempt unsucessfully
    what to] reinstall,' I've no idea, the foggiest clue, except Winderz
    is not the system, a system itegral, but Winderz is on a system, the
    laptop itself, which systematically and properly will run all kinds of
    stuff besides Winderz.

    Yes, Winderz does and would have a system, of sorts and in a sense,
    within a broader latitude generally given hardware, as might you
    suspect, although there's, conceptually, both a Winderz idea and your
    idea of how that ought be accomplished. It's cognitively something
    called kludge by people capable of approaching at times different
    means than an end to Microsoft's Knowledge Base;- Personally I all but
    deplore a drive formatted to NTFS, and use pretty much use Easeus
    Partition Manager for building FAT32 storage repositories excluvise to
    broader sense of available resources that may favor developers of
    3rd-party drive and file utilities. ...Opening up to play what angles
    may have to offer.
     
    Flasherly, Jul 8, 2013
    #10
  11. Note that that means it's not the Cypress problem but the partition
    table is gone.
     
    Loren Pechtel, Jul 9, 2013
    #11
  12. I simply wouldn't use any repair-in-place tools unless I could
    actually preview what they're going to do first. Work on copies if
    it's important!

    (And note that I've been messing with this sort of stuff off and on
    for ages. I've done many an undelete when that meant a raw sector
    editor on the TRS-80 and the Apple IIe. I worked with a notepad next
    to me to write down the original values of anything I was changing.)
     
    Loren Pechtel, Jul 9, 2013
    #12
  13. You like living dangerously! One copy of important data on an 8 year
    old drive?

    I wouldn't have one copy, period. I've sent too many drives back
    under warranty.
     
    Loren Pechtel, Jul 9, 2013
    #13
  14. emekadavid

    John Doe Guest

    You should have had a copy of any important files.

    Make a copy(s) before even thinking about doing any repair work.

    After trouble strikes, it might be too late, but you make a copy
    before doing anything else. If you can't make a copy, you are sunk.

    The worse the trouble, the more copies you should have.
     
    John Doe, Jul 9, 2013
    #14
  15. emekadavid

    emekadavid Guest

    thanks. tried testdisk just to see and got blue screen of death.
     
    emekadavid, Jul 9, 2013
    #15
  16. emekadavid

    emekadavid Guest

    thanks. won't do it again
     
    emekadavid, Jul 9, 2013
    #16
  17. emekadavid

    emekadavid Guest

    think of installing a partition manager, load fedora on a partition and then check the disk. easeus recognises disk but can't recreate partition. means possibly data is lying low in disk. thanks. winderz is all we have where i live; if u want to survive
     
    emekadavid, Jul 9, 2013
    #17
  18. emekadavid

    Flasherly Guest

    On Mon, 8 Jul 2013 20:55:59 -0700 (PDT), emekadavid
    load fedora on a partition and then check the disk. easeus recognises
    disk but can't recreate partition. means possibly data is lying low in
    disk. thanks. winderz is all we have where i live; if u want to
    survive

    -
    There are two easeus - 1) is a messed-up *Partition Restorer* and 2)
    a deleted file recoverer. I suppose you tried the first (even though
    I only mentioned the second). Easeus has gotten my butt out of some
    soulfelt heartaches a couple times.

    ** http://www.easeus.com/partition-recovery/

    Sounds pretty serious if neither is of any help. Of course with
    partition/file losses, when they happened, I didn't wait, screw
    around, but went straight into the recovery routines. I've also used
    both, btw, and spent more hours than you want to know with the file
    recovery routine before happening on or figuring just to get the
    partition back with this new link provided above, if that's at all
    possible at this point in your case.

    Running XP here. No idea where I'd be if I hadn't taken backups
    seriously since way back when. (Even though it's a different game now,
    an expensive one when talking stacks of massive HD storage, assuming
    duplicating them. The other angle is worse: culling them for most
    important data, which means a lot of decision work on a compromised
    solution at best. That I'm certainly not *totally* covered would be
    the worst/best way to put it;- you choose.)
     
    Flasherly, Jul 9, 2013
    #18
  19. emekadavid

    emekadavid Guest

    Thanks, I have graphics of the easeus partition recovery process.
    first image: Data recovery > partition recovery > search all lost files: the system recognises the disk as Initio INIC-1511 USB Device
    http://dl.dropboxusercontent.com/u/72417354/general/first.PNG
    second image: on next, it reports 0.0kb 0 files in disk. Lost disk? any suggestions? do you think the virus scan file deletion is the problem or was the disk compromised?
    http://dl.dropboxusercontent.com/u/72417354/general/second.PNG
    third image: Partition Recovery. On choose a disk to recover, the Initio INIC-1511 USB Device was not listed. ???
    http://dl.dropboxusercontent.com/u/72417354/general/third.PNG
     
    emekadavid, Jul 9, 2013
    #19
  20. emekadavid

    Paul Guest

    So this is your hard drive.

    "Hitachi GST Travelstar 5K500.B HTS545025B9A300 (0A57912)
    250GB 5400 RPM 8MB Cache 2.5" SATA 3.0Gb/s Notebook Hard Drive"

    http://www.newegg.com/Product/Product.aspx?Item=N82E16822145255

    I would pull the drive from the enclosure, and test while
    connected to a SATA port on the computer.

    Someone here, reports an INIC-1511 failing, and not
    allowing the disk to be read. And connecting the
    drive to the computer directly, worked for that drive.

    http://forum.eeeuser.com/index.php?...ve-not-used-for-a-while-and-now-not-mounting/

    To me, the INIC-1511 appears to be an IDE chip,
    so there might be an IDE to SATA chip external
    to the INIC-1511, to allow connection to SATA drives.

    http://imageshack.us/a/img89/1436/ga7.gif

    Your Easeus software mentions it doesn't support Dynamic Disk,
    which is another reason the recovery effort may have failed.

    I'm still trying to figure out, what the blue screen caused
    by TestDisk means... Very puzzling. I'm not aware of any other
    reports of TestDisk failing.

    Paul
     
    Paul, Jul 9, 2013
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.