IE7, printing and Vista revisited

Discussion in 'PC Technical Talk' started by Bill, Jun 22, 2008.

  1. Bill

    Bill Guest

    This all started when her indoors wanted a new kitchen floor and I tried
    to print some documents from the B & Q website. A posting here drew no
    response, so hopefully this might alert others to the problem and help
    avoid the wasted time I've spent on it. Two MSVP's on another newsgroup
    pointed the way, and I'm very grateful to them


    To recap, I couldn't print from IE7 on either of 2 Vista machines to an
    HP 1210 AiO printer running via an XP host machine on the network.
    Printing from other programs and Firefox worked fine. There were no
    error messages, printing just silently didn't happen. All drivers were
    up to date and all Microsoft updates applied.

    Connecting a Vista machine directly to the printer made no difference.
    Still no print from IE7.

    Switching IE7 out of protected mode cured the problem ....or ...
    Uninstalling AVG 8 also cured the problem.
    (I'm told that Kaspersky, AVG and Avast all have the same effect.)

    It appears there must be some interaction between much AV software and
    IE7's protected mode that stops that HP printer driver from working
    correctly. An internet search indicates that many HP printers exhibit
    the same problem, but at least there are some workarounds, even if they
    are a bit awkward.

    I have replaced the HP 1210 with an HP C8250. Presumably this uses
    different drivers as it prints fine from Vista + IE7 with protected mode
    on and AVG8 installed.
     
    Bill, Jun 22, 2008
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.