HP Pavilion DV9500 - Back light working, no image displaying

Discussion in 'Hardware' started by S Walch, Oct 10, 2011.

  1. S Walch

    S Walch MAME 0.64 :) VIP Member

    Joined:
    Jun 2, 2003
    Messages:
    1,026
    Likes Received:
    14
    Location:
    Manchester
    Pretty much explained in the title; I've got a HP Pavilion DV9500, and when I turn it on, the LCD's back light is coming on, but there is no image on screen (no POST displaying at all), it's just black.

    It's already had a new screen, a new inverter, and now a new Ribbon cable. I've already tried the LCD on another laptop and it's working fine, and I've pretty much replaced every component that works in conjunction with the graphics/image.

    I've also tried hooking it up to an external monitor, and also tried it without the battery in.

    The thing is, I can still hear the Windows startup jingle, and pretty much everything else in the main section appears to be working normally - I just can't view anything.

    Possible causes? New motherboard needed perhaps?

    Edit: Before it get's suggested: I've already taken out and reseated the RAM, as well as switching in some RAM that I knew was working perfectly - still nothing changed
     
    Last edited: Oct 10, 2011
    S Walch, Oct 10, 2011
    #1
    1. Advertisements

  2. S Walch

    Nickweb Resident Filmaker Moderator

    Joined:
    Nov 7, 2003
    Messages:
    2,532
    Likes Received:
    27
    Location:
    North Wales, Britain
    Only thing I could think of is the GPU failing
     
    Nickweb, Oct 10, 2011
    #2
    1. Advertisements

  3. S Walch

    Goober THQ's Jester Moderator

    Joined:
    Jul 26, 2004
    Messages:
    2,864
    Likes Received:
    35
    Location:
    Colorado
    2nd the motion, all in favor say arrrhg.
     
    Goober, Oct 10, 2011
    #3
  4. S Walch

    S Walch MAME 0.64 :) VIP Member

    Joined:
    Jun 2, 2003
    Messages:
    1,026
    Likes Received:
    14
    Location:
    Manchester
    That mean I'd need to sort it out with a new motherboard?

    Bleugh. May as well tell the person it belongs to to get a new one instead
     
    S Walch, Oct 10, 2011
    #4
  5. S Walch

    Maurice Bloody good bloke VIP Member

    Joined:
    Jun 25, 2009
    Messages:
    352
    Likes Received:
    16
    Location:
    London England
    It certainly looks that way. As you say, it seems to boot up into windows ok and as there's no display on either the lcd display or an external monitor I agree that it looks like the graphics chip/circuits are snafu'd. With a PC you can always stick a graphics card in, with a lappy you are stuffed as everything is on the one board.
     
    Maurice, Oct 11, 2011
    #5
  6. S Walch

    darthweb VIP Member

    Joined:
    Jan 9, 2006
    Messages:
    1,600
    Likes Received:
    7
    Have a search on ebay for DV9500 ... all faulty & spares repairs units with similar mobo graphics problems.

    I'd give it up :crash:
     
    darthweb, Oct 11, 2011
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.