HP MSA 1500 - Hubs for redundancy?

Discussion in 'Storage' started by Kat, Jun 2, 2005.

  1. Kat

    Kat Guest

    We have an MSA 1500 with dual controllers. Each had a single HBA, and each
    HBA attached to a seperate switch. When one of the HBA's in a server failed,
    we discovered that the path to the standby controller did not function,
    obviously. So we were told my HP to buy a switch or a hub to rpovide access
    from each controller to each switch- the hub was signicantly cheaper.

    So now we have 2 - 2 port hubs rather than a single HBA. And when I enable
    the port where the second port in the hub is attached to (on the opposite
    switch of the working one) we get 2 failed ports. I've contacted HP, and
    they're lookign into it... any ideas? Is there some kind of conflicting
    path?
     
    Kat, Jun 2, 2005
    #1
    1. Advertisements

  2. I'm not entirely sure I follow you. "Each had a single HBA" Each MSA1500
    controller? They're normally not called HBAs, rather I/O modules.
    In any case, each controller connected to a seperate switch is perfectly
    valid high-availability configuration.

    Or do you mean each server had a single HBA? Can't see why you should need
    to mix in hubs or more switches.

    If you could draw me a simple diagram of each of the setups you've tried I'd
    be happy to help. Email adress is valid. Please include server OS in the
    diagram
    /charles
     
    Charles Morrall, Jun 2, 2005
    #2
    1. Advertisements

  3. Kat

    Kat Guest

    Sorry Charles :) Yes, I meant each I/O module on the controllers.

    We have 2 switches, and each server/MSA has a connection, one to each
    switch. Now, the msa has 4 connections- each controller conencts to both
    switches. At least this is what we're trying to do- the hubs don't seems to
    like having multiple connections.When I enable the second port on the
    switch, that the msa controller is connected, both the ports that that
    controller is connected to will fail. If I disablet he second port, it works
    fine.

    I can draw a quick diagram if you need one.

    Thanks
     
    Kat, Jun 2, 2005
    #3
  4. I don't see any reason for the hubs. Infact, they could be making matters
    worse.

    Each server should have two HBAs, connected to the respective switches. So
    should the MSA1500 controllers, each I/O port connected to the respective
    switch. The MSA1500 controllers are active/passive, meaning the entire load
    is on one controller. The redundant controller is idling, waiting for either
    the controller to fail or a path from a server to fail. This means any
    single-attached server will lose connection if the controller pair fails
    over.

    Things to check:
    Do all servers have two HBAs, each connected to seperate switches?
    Are the HBA drivers up to the minimum supported version?
    What is the OS on each server?
    Do you have multipath drivers loaded? SecurePath or MPIO? What version?
    Is there any zoning on the switches? What model of switch? Firmware on
    these?
    Is the firmware updated on the MSA1500?
    Have you confirmed there are no bad cables, SFPs, HBAs?
    How is Selective Storage Presentation (SSP) configured on the MSA1500? Are
    there two WWID entries for each server?
     
    Charles Morrall, Jun 3, 2005
    #4
  5. Kat

    Kat Guest

    "The redundant controller is idling, waiting for either
    the controller to fail or a path from a server to fail. This means any
    single-attached server will lose connection if the controller pair fails
    over."

    This is incorrect- if a single connection to a server fails, it will fail
    over to the other switch. But the passive/redundant controller does NOT
    become active- it will only become active if the other controller fails. So
    essentially, that path is useless. It can connect to the passive controller,
    but that controller can't do anything.

    As it stands, everything is working, in the way you describe it. We have
    multiple servers attached to the switches, all dual path, all with
    securepath and W2003, and yes there are two WNNs for each server showing on
    the MSA. The config is correct- it's just a matter of getting the redundancy
    to work for each controller (attaching each controller to each switch).

    Since HP recommended we do this, I'd assumed it would work, but I can't find
    anyone else who has it configured this way. I'm starting to have doubts :)
     
    Kat, Jun 3, 2005
    #5
  6. Well, it's supposed to work that way :)

    Just a thought, are the switches connected to each other?
    /charles
     
    Charles Morrall, Jun 6, 2005
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.