Amazon Kindle for PC causes BSOD in Windows 8.1

Discussion in 'PC Hardware' started by RayLopez99, Nov 24, 2014.

  1. RayLopez99

    RayLopez99 Guest

    Blue Screen of Death caused by Amazon Kindle for PC software in Windows 8.1, with a modern computer system (few years old).

    Happens every so often, and I'm fairly certain it's caused by this program,which takes forever to synch, and further fails to download all books properly (some reside on other PCs, but they should be downloadable from the Amazon server to any PC I own, up to I think three or so devices).

    I have experience with PCs and am fairly certain the Amazon program is causing the BSOD.

    Further the program is constantly trying to synch with the Amazon server, even though I have a fast internet connection, and it shows the "circular hourglass" repeatedly as it tries to synch.

    These problems, aside from the BSOD, are reported in the official Kindle website, but I don't want to go through the hassle of registering in that forum, and risking having the moderator delete this post, so I post here.

    Very disappointed with this software.

    It does however 'work', except when it does not, and aside from often asking you to download yet again some Kindle edition book you've already downloaded, it does remember the last page read. It is buggy however.

    RL
     
    RayLopez99, Nov 24, 2014
    #1
    1. Advertisements

  2. RayLopez99

    Paul Guest

    The only recent change of significance on servers,
    is the move away from SSL to something like TLS. I get
    sporadic failures here (no BSOD), when a server stops
    accepting one of the protocols. The behavior changes with
    time of day. I don't know if they're experimenting on the
    server end or what the excuse would be. On web sites with
    advertising, sometimes the advertising code pops up a
    notification that the protocol it wants is missing (which
    makes me happy, as I'm not turning SSL back on for them).

    I would drag out my packet sniffer, and see whether SSL or
    TLS is being used. Or an attempt is being made to use them.

    And I would try and find the .dmp file, and do a check
    on that, for some evidence. Either dumpchk or BlueScreenView
    from Nirsoft. The dumpchk has always worked for me, but it's
    a download from Microsoft.

    Microsoft had a recent patch for Schannel, but I doubt that
    has anything to do with it. The Schannel would not be
    patched on WinXP.

    http://en.wikipedia.org/wiki/SChannel

    "Secure Channel (aka SChannel) - Introduced in Windows 2000 and
    updated in Windows Vista to support stronger AES encryption and
    ECC [Elliptic Curve Cryptography]. This provider uses SSL/TLS
    records to encrypt data payloads. (schannel.dll)"

    But usually when these things break, I expect them to break
    during the "Hello" stage and not the "Here's Another Packet"
    stage. The negotiation phase is the most likely to fail.

    Paul
     
    Paul, Nov 24, 2014
    #2
    1. Advertisements

  3. RayLopez99

    RayLopez99 Guest

    Further information. Thanks Paul.

    It might be a bad disk. I ran CHKDSK /F and also the right click on Tools | repair disk for Windows 8.1 and it seemingly corrected the problem, but, I don't think it's corrected. What happens is somehow it 'glosses over' the problem, doing "online repairs" and other such stuff of corrupted files, but (and I am pretty sure I don't have a virus, I run Microsoft's free Windows Defender in Full Scan mode regularly) everytime I "check disk for errors" it will prompt me to repair (I am sure it would happen again, though I've not tried it yet).

    The thing is this HD was swapped with my other HD (SATA 3) a while ago, because the other HD was too slow, now however this HD seems to have bugs.

    I don't have anything mission critical on here, and I do backup important files, but since this HD problem exists it's annoying...will report later ifI find something of interest.

    Right now I'll just grin and bear it. But the problem seems to have arisenwhen I installed Kindle for PC hence my original post. But it might be a coincidence.

    Any free HD tools? Other than what's built into WIndows 8.1?

    RL
     
    RayLopez99, Nov 24, 2014
    #3
  4. RayLopez99

    RayLopez99 Guest

    Aggh!!! Too much information to explain, but to get an idea of what is going on, check out this thread: http://www.eightforums.com/drivers-hardware/18812-restart-repair-drive-errors-keep-showing-up-2.html

    ....note the "indeterminate" nature of the "fixes". Very instructive on howpeople workaround / fix this problem. Note the one guy who reinstalled, it failed, then the error mysteriously disappeared; note the other guy who uninstalled AdBlock (which I also have in Firefox) and the problem disappeared.

    Also see the below log file, and ponder this:

    1) Perhaps Adblock uninstalled will solve the problem? I will do this.

    2) "online" repair of your hard drive by Windows 8.1 seems to 'mask' the problem (by temporarily fixing problem HD sectors), so this problem may have been going on for years?

    3) it may be hardware related (failing hard drive). I bought this hd 'new'in se asia this year, but everything in this part of the world is refurbished. I am 95% convinced they get stuff second hand from the USA and resellit. I got it as a 'very good price' too, which is suspicious

    4) nothing mission critical on here, except my Visual Studio 2013 files, which I backup daily using 7-Zip. Worse case I do a clean reinstall, which will waste a day or two, but I'd like to avoid that.

    5) this Please run chkdsk /spotfix to fix the issues. might help, though I've already done chkdsk / R (repair) with no effect

    6) this might be a 'nuisance' rather than a hard stop. It might be responsible for an occasional BSOD. It prevents me from doing a Ghost image backup, except when I go "outside" the system and use CloneZilla on a CD-ROM. This is 'new' (did not happen before).

    7) pretty sure not a virus. I do full scan all the time and find nothing.

    8) Quad-core i5, 32 bit Windows 8.1, memory is 4 GB and seated properly, HDs are Seagate 1TB and Western Digital 500 MB, the former 'new' (see above) the latter five years old, hence used for backup only as drive "D".

    9) I do use CCleaner on occasion, which I know Paul hates, but it does not seem to do harm. Could, over the years, this be a wrong assumption? I doubt it, but it's possible.

    RL

    Partial Event Viewer log...lots of entries deleted... this is a Seagate 1TBdrive C:


    Chkdsk was executed in scan mode on a volume snapshot.

    Checking file system on C:
    Volume label is Seagate.

    Stage 1: Examining basic file system structure ...
    Found 0x9e clusters allocated to file "\Users\USER\MyDir\programming.7z<0x193,0x41c0>" at offset "0x3b3d3" marked as free
    ... repaired online.

    Attribute record of type 0x80 and instance tag 0x3 is cross linked
    starting at 0x2c27974 for possibly 0x3e0 clusters.
    Found corrupt basic file structure for "\Windows\System32\wdi\LogFiles\BootCKCL.etl <0x1,0xa71b>"
    ... repaired online.
    Found corrupt basic file structure for "<0x28,0x15bd1>"
    ... repaired online.

    Attribute record of type 0x80 and instance tag 0x1 is cross linked
    starting at 0x2d788c for possibly 0x10 clusters.
    Found corrupt basic file structure for "<0x1c,0x15cdf>"
    ... repaired online.
    Found 0x80 clusters allocated to file "<0x28,0x15cea>" at offset "0" marked as free
    ... repaired online.
    Found corrupt basic file structure for "<0x28,0x15cea>"
    ... repaired online.

    "\ProgramData\Microsoft\Windows Defender\Scans\History\Results\Resource <0x1,0x763>"
    ... repaired online.
    Found an unneeded link ($FILE_NAME: "{D0EA0~1") in index "$I30" of directory "\ProgramData\Microsoft\Windows Defender\Scans

    \History\Results\Resource <0x1,0x763>"
    ... repaired online.

    Stage 1: Examining basic file system structure ...
    Some clusters occupied by attribute of type 0x80 and instance tag 0x3
    in file 0xa71b is already in use.
    Deleting corrupt attribute record (128, "")
    from file record segment 42779.

    CHKDSK is scanning unindexed files for reconnect to their original directory.
    Recovering orphaned file S-1-5-~4.LOG (89041) into directory file 147237.

    Usn Journal verification completed.
    Windows has found problems and some were fixed online;
    the remaining problems must be fixed offline.
    Please run chkdsk /spotfix to fix the issues.
     
    RayLopez99, Nov 24, 2014
    #4
  5. RayLopez99

    Paul Guest

    There was a problem with dual booting, and each time
    afterwards, the partitions would end up getting checked.
    I shut off hibernate on Windows 8 with

    powercfg -h off

    and it might be a coincidence, but the chkdsk thing stopped.
    I used to dual boot between Windows 8 and WinXP, but the
    Win8 disk is disconnected right now. (If I'm not using it,
    there's no reason to keep it spinning. If the percentage
    of the time I was in there was higher, I'd leave it running.)

    I might have also adjusted disk spindown times, and tried
    to use Power Options to keep the disks spinning at all times.
    But some disks may spin down anyway, even though you don't
    want them to. I make it a rule, to read reviews for disks
    (customer reviews), to make sure I'm not buying a disk model
    that spins down the drive 400 times a day. There was one
    Seagate model, where the 500GB was fine, and the 1TB and 2TB
    of the same model line, were "spindown crazy".

    Your chkdsk pattern almost looks like a dirty shutdown,
    like the things open at the end of an OS session got
    chopped. Certainly the error types are a bit different
    than anything I've seen here. Almost like disk errors
    rather than software side effects.

    I haven't had a chkdsk here, in maybe a year or so.
    I would have expected the Windows 10 Preview to have
    kicked up a stink, but there hasn't been
    a CHKDSK on that machine. I just don't have the
    right test pattern there now, to look for the old
    CHKDSK thing.

    As for third-party CHKDSK, there are companies that have
    tried, but I can't say I've run into anyone who has used
    that. And I don't know if the Linux people are interested
    or not. As it is, Linux tends to ignore security on NTFS,
    and a side effect of that is perhaps they don't have the
    entire structure down pat. So their CHKDSK wouldn't
    be thorough enough. And if they ever do turn on the security
    stuff, that'll be the end of Linux for NTFS maintenance
    tasks. It's just better to be doing the CHKDSK in Windows
    (such as it is).

    The later Windows OSes have some sort of "robust" maintenance
    feature, where they constantly check the NTFS partition
    (perhaps after a write or something). But since I wasn't able
    to find sufficient detail to understand it, I can't comment further
    on exactly what we're supposed to do when problems arise. You
    would think a CHKDSK from recovery console, would be a good way
    to do it, as then perhaps the older methods might be available
    (less high tech method).

    (On Windows 8, you can boot the installation DVD, to get
    to the Recovery Console. It's just command prompt, and you
    can use the CHKDSK there. Naturally, the command line parameters
    will be slightly different, in each environment where a
    copy of CHKDSK is offered.)

    You will obviously have a different set of software on there,
    than what I run. My Windows 8/8.1 stuff is pretty clean
    in terms of installed software. I think on one machine,
    I might even have Windows Defender turned off (annoying
    software tends to get turned off here). So I'm probably
    not bashing this stuff hard enough to unearth problems.
    It's possible I was doing a software update of some
    sort, noticed Windows Defender sniffing all the files,
    and I turned it off. So the update would go faster.

    There's nothing wrong with CCleaner - just not for the
    Registry. Leave the Registry alone, would be my advice.

    Paul
     
    Paul, Nov 24, 2014
    #5
  6. RayLopez99

    RayLopez99 Guest

    I think I am stuck with this 1TB Seagate HD drive *specs below, it's 'brandnew-refurbished' until it crashes--I will backup critical files like my programming source code on a daily basis to a USB and to the D: drive. It also might be something to do with the Mobo, since there was lots of thrashing even with the earlier 500 MB Western Digital HD (why I switched to Seagate, which does spin faster and is faster than the older WD drive).

    Running the "Check disk" option under right-click on drive in Windows Explorer will always find an error, then when you reboot it does its version of Chkdsk, and then, when you re-run 'check disk' it will say: "You don't needto scan this drive. We haven't found any errors on this drive. You can still scan the drive for errors if you want", which is a BALD-FACED LIE! :) since if you do go ahead and run the diagnostic, Windows will always find errors. Consequently as I say, no Image Backup program like Acronis will work (it will seize up the machine) but Linux based DVDs like Clonezilla thatwork outside of Windows do work to backup.

    I noticed further that since these errors were caught, Windows 8.1 has created a new "F: " drive for the "C" drive, called System Reserved, 349 MB large, and while I do understand the nature of this virtual drive, it's strange that it appeared now, but further Googling shows "The System Reserved partition is used... also holds the Windows Recovery Environment (WinRE) and boot files with boot manager for booting up the computer for troubleshootingwhen there is no Windows 7 installation DVD disc on hand" which makes sense--all of the rebooting and troubleshooting is going into this 'new' "F:" drive partition that is part of "C:".

    I might run the original Windows 8.1 DVD (and ironically it's a Genuine Copy that's giving me problems, usually for these 'throwaway' machines that are not mission critical I use pirate Windows) and see if that helps, but, asPaul implied, I don't think this is a "system file" problem but like Paul says a HD problem (or maybe even a BIOS problem? But the BIOS is from 2011,not that long ago, and should be OK).

    Maybe not coincidentally I did do a hard power reset once or twice before these problems were noticed, but I doubt that had anything to do with it. Ithink that these problems were latent for years, it's just now that I noticed them. This system always, despite having an i5 quad core, had sluggishmechanical hard drives.

    BTW for Power Options I have "High Performance" checked.

    Any further pointers appreciated. I am now a believer in getting quality, genuine hardware components if available (like having a machine built in the USA and the shipped to me, as I'm outside the USA). Part of the problem is that this was a typical 'low price' southeast Asia machine, and, as I say, they don't use genuine parts on anything but the uP (and I wouldn't pay for a 'custom' PC here, since I doubt the components are genuine or much better than a cheaper PC--except maybe for the case, which would look 'radical' and maybe have water cooling, etc). In fact, they don't even have ground wires in this part of the world, and you have to use UPS as a sort of 'floating ground' which means after several months of brownouts (if not sooner) you need to replace your UPS battery since it will be shot (since it's acting as an accumulator or surge suppressor; I've had it literally swell thecase of the UPS after a particularly nasty electrical storm was sending thunderbolts all around the house).

    RL


    * specs:
    http://www.seagate.com/internal-hard-drives/desktop-hard-drives/desktop-hdd/?sku=ST1000DM003

    Barracuda Desktop 6-Gb/s 1TB Hard Drive
    ST1000DM003

    Cache, Multisegmented (MB): 64
    SATA Transfer Rates Supported (Gb/s): 6.0/3.0/1.5
    Seek Average, Read (ms): < 8.5
    Seek Average, Write (ms): < 9.5
    Average Data Rate, Read/Write (MB/s): 156
    Max Sustained Data Rate, OD Read
    (MB/s): 210
     
    RayLopez99, Nov 24, 2014
    #6
  7. RayLopez99

    RayLopez99 Guest

    Overnight I confirmed that Filezilla seems to work to backup the disk but does give error warnings periodically (I did not verify the image) but at least it finishes the job.

    And turning off " Akamai NetSession", which you can do from "Startup" tab in Task Manager, more info here: http://www.akamai.com/html/solutions/client_faq.html#q7 does seem to help prevent disk thrashing at startup (you canalways turn it on if you need it later, the control panel for this client program, which uses your bandwidth and HD in a sort of peer-to-peer network, is found here: C:\Users\YOURUSERNAMEHERE\AppData\Local\Akamai\ControlPanel.exe

    RL
     
    RayLopez99, Nov 25, 2014
    #7
  8. RayLopez99

    RayLopez99 Guest

    This thread was useful...note the two programs have been updated this year (links added) in Microsoft's website...

    RL

    http://www.reddit.com/r/techsupport...ows_8_high_disk_usage_usually_around_100_and/

    Get two programs: Process Explorer [http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx], and Process Monitor[http://technet.microsoft.com/en-us/sysinternals/hh290819]. Anytime you run these, make sure you run as administrator.

    Using task manager, find the PID of the task that is causing problems. Thenopen Process Monitor and create a filter to display only results with thatPID, as well as anything else you want to specify (ex., only display read/write, etc.)

    After you capture for a bit, you will have a very thorough list of everything that has happened with that PID. Make sure you are able to view two specific columns of information: TID and Duration.

    At this point, I would recommend saving the Process Monitor output as a CSVfile and opening it with Excel. Then you can use a few quick formulas and sorting to find which TID(s) are taking the longest. (If your not good withExcel, feel free to PM me your CSV file and I can help with this part.)

    From there, you can use Process Explorer (important to run as admin) to locate the PID that is causing issues. If you double click the PID you can getmore information, including a list of threads (and their corresponding TIDs) and determine what module (probably a dll file) corresponds with the problem TID. From that, you should be able to determine which service specifically is causing problems, and either disable it or take whatever steps necessary to fix it.
     
    RayLopez99, Nov 25, 2014
    #8
  9. RayLopez99

    RayLopez99 Guest

    I think I might end up doing a clean reinstall of Windows 8.

    However, going through this thread and reading between the lines: http://www.eightforums.com/performance-maintenance/22547-sfc-shows-unable-fix-corrupt-files.html

    I think I know maybe what happened. These problems showed up in Windows sometime after when I cloned a smaller WD HD (512 GB) onto a larger Seagate HD (1 TB). In theory it's not a problem, but in practice I think it confusedWindows, which might have anti-piracy keys embedded in it that compound this problem. My OS is a genuine copy of Windows 8.1 running on a fairly newquad core PC.

    The reason is that sfc /scannow finds numerous 'errors', not really errors,but it causes perpetual potential false positives when doing chkdsk and disk repair. Below are some of these 'errors' (in practice there's about 30 pages of this, I just picked some representative examples). You can 'fix' these errors by running chkdsk, and then do a HD image backup (I use Clonezilla), but, a few days or hours later, the errors reappear.

    RL

    sfc /scannow gives (sample output):

    2014-11-26 18:46:08, Info CBS Session: 30411110_795857431 initialized by client WindowsUpdateAgent.
    2014-11-26 18:46:08, Info CBS Failed to internally openpackage. [HRESULT = 0x800f0805 - CBS_E_INVALID_PACKAGE]

    2014-11-26 18:59:05, Info CSI 00000274 [DIRSD OWNER WARNING] Directory [ml:520{260},l:64{32}]"\??\C:\Windows\Offline Web Pages" isnot owned but specifies SDDL in component Microsoft-Windows-IE-OfflineFavorites, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf4856ad364e65}, Type neutral,TypeName neutral, PublicKey neutral

    014-11-26 18:59:14, Info CSI 0000028c Ignoring duplicate ownership for directory [l:58{29}]"\??\C:\Windows\System32\el-GR" in component Microsoft-Windows-LSA-MSPrivs.Resources, Version = 6.3.9600.16384, pA = PROCESSOR_ARCHITECTURE_INTEL (0), Culture = [l:10{5}]"el-gr", VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf4856ad364e65}, Type neutral, TypeName neutral, PublicKey neutral
     
    RayLopez99, Nov 26, 2014
    #9
  10. RayLopez99

    Dustin Guest

    I'm surprised you have a kindle? Or, is this a clients? Are you passing
    yourself off as some kind of tech again, Ray?
    Well, you were certain that in21 in assembler source stood for integer,
    too. So much for that though.
    *laugh*
     
    Dustin, Nov 26, 2014
    #10
  11. RayLopez99

    Dustin Guest

    If you think the mobo might be at fault, I wouldn't be saving just to
    drives connected to it directly. You should also be burning your
    programming source to cd-r. I'm sure you don't have anything you
    can't retype from a book, though.
    Windows 8.1 isn't always finding an error on a laptop sitting here.
    Sounds like you have something going on with your gear.
    hd0, you mean. C: is actually another partition, similar to F:
    The age of a BIOS alone determines if it has problems? [g]

    It doesn't sound to me like you have a good idea what's going on with
    the machine. If I didn't know you already as a scouring usenet troll
    from another newsgroup, I'd be glad to try and help you out here.


    Why would a pirate version of windows (What exactly are you calling
    pirate version?) do any better than the original? Assuming their both
    equal on service packs.

    Why are you even discussing pirate windows in a pc building
    newsgroup? That's probably not considered kosher here, troll.
    That must have been quite a sight.
    I'm not a fan of seagate...
     
    Dustin, Nov 26, 2014
    #11
  12. RayLopez99

    Dustin Guest

    It's finishing the job by ignoring data fragments or entire files it
    cannot read. You really should review the log file if it left one
    behind. It doesn't matter if some specific files didn't get backed up
    or were only partially backed up... It does matter if other specific
    files didn't though.
     
    Dustin, Nov 26, 2014
    #12
  13. RayLopez99

    Dustin Guest

    Nope. You do not know what has happened. Your speculation above is
    more science fiction than fact, too.
    anti piracy keys embedded? hehehehehe... er, not in the sense your
    thinking, no.
    You really don't know what you're looking at here... lol These are
    not phantom or non existant errors. You have an actual problem here,
    stupid.
     
    Dustin, Nov 26, 2014
    #13
  14. RayLopez99

    Jax Guest

    Dustin why don't you like Seagate? Just wondering.
     
    Jax, Nov 26, 2014
    #14
  15. RayLopez99

    Dustin Guest

    You act as if I owe you a reasonable answer.

    Wonder why you didn't get one for a bit.
     
    Dustin, Nov 27, 2014
    #15
  16. RayLopez99

    Dustin Guest

    Are you going to google follow me and post to every newsgroup you see
    me posting in? Dumbass.
     
    Dustin, Nov 27, 2014
    #16
  17. RayLopez99

    RayLopez99 Guest

    See my latest post, which makes a mockery of all your posts in this thread. It was not a hardware problem Einstein.

    Oh, and that's not your truck leaking...it's your bowels and bladder, Mr. Depends.

    RL
     
    RayLopez99, Nov 27, 2014
    #17
  18. RayLopez99

    Dustin Guest

    I haven't seen your latest post yet. I didn't provide any diagnosis
    with my replies. Just some cute commentary.
     
    Dustin, Nov 27, 2014
    #18
  19. RayLopez99

    Dustin Guest

    MID? Your latest post isn't showing up in this thread...
     
    Dustin, Nov 27, 2014
    #19
  20. RayLopez99

    Dustin Guest

    I've reviewed your post. I don't see how you think it makes a mockery
    of anything I wrote. Actually, it confirmed my suspicion and comment.
    You didn't know what you were doing and you still don't.

    You're taking wild guesses and making some silly assumptions about what
    you think went wrong, but you don't know at the end of the day. You
    resorted to a clean reinstall. I'm assuming by clean, you actually
    formatted the drive too?

    So now you're spending the next couple of days reloading your box. You
    took the desperate act of reformatting to fix the issue you were
    having. I never thought you were much of a tech. now, I know you
    aren't. Your questions had me rolling in stiches!
     
    Dustin, Nov 27, 2014
    #20
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.