32-bit Win 7 driver for a strange Intel S82557 network

Discussion in 'PC Hardware' started by Man-wai Chang to The Door (33600bps), Mar 10, 2010.

  1. Following was printed on the chip:

    S82557
    L6485369
    SZ758
    I(m)(c)1989 1995

    Win 7 failed to find a driver for it. I downloaded PROWIN32.EXE from
    Intel, but it also failed to install.

    The card was detected by WinXP without issue.

    So where is the driver for this card?
     
    Man-wai Chang to The Door (33600bps), Mar 10, 2010
    #1
    1. Advertisements

  2. Man-wai Chang to The Door (33600bps)

    Paul Guest

    The Intel site claims the 82557 uses an "in-box" driver for
    Windows 7. That means, when you installed Windows 7 on that PC,
    the 82557 should have been detected and installed using a driver
    already in Win7.

    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=18268&lang=eng

    Go to this site, and type 82557 in the search box. Then select the OS.

    http://downloadcenter.intel.com/Default.aspx

    Paul
     
    Paul, Mar 10, 2010
    #2
    1. Advertisements

  3. The Intel site claims the 82557 uses an "in-box" driver for
    This is funny! That PC has only the 82557 card. How could I access
    Window$ Update *BEFORE* the driver for the 82557 was not installed?
    I tried. Did you find something interesting which I missed?
     
    Man-wai Chang to The Door (33600bps), Mar 10, 2010
    #3
  4. Man-wai Chang to The Door (33600bps)

    Paul Guest

    By using the search box, I was able to find the page that
    says the driver is an "in-box" type.

    In other words, Intel is *not* offering a driver for download
    for 82557 in a Windows 7 system, because they claim the
    driver has been included by Microsoft, on the DVD.

    What should have happened:

    1) Install Windows 7 on the PC.
    2) 82557 networking starts working right away.

    I tried downloading a ProWin32.exe driver, and there is no
    support in there for 82557 in the NDIS62 folder.

    *******

    I downloaded the Windows 7 evaluation from last year, a 2.2GB DVD
    image, and took a look in there, for the "in-box" driver. My best
    guess is.

    7100.0.090421-1700_x86fre_client_en-us_retail_ultimate-grc1culfrer_en_dvd.iso

    sources\install.wim\1\Windows\inf

    netefe32.inf

    PCI\VEN_8086&DEV_1229

    It could be that file, which controls installation. You might try and
    check, with something like "lspci" in a Linux LiveCD, and see if the
    device declaration has that VEN and DEV. It looks like you might need
    to match on SUBSYS as well, and perhaps that is why it didn't install.
    Hacking that INF file might fix it.

    (I used http://pciids.sourceforge.net/pci.ids to find the values for 82557)

    8086 Intel Corporation
    1229 82557/8/9/0/1 Ethernet Pro 100

    My best guess,
    Paul
     
    Paul, Mar 10, 2010
    #4
  5. Thanks. I guess my only solution is to borrow a network card that's
    correctly supported by Win 7, then fetch the driver for 82557, and keep
    a copy of it by finding the CAB file from the WindowsUpdates.log!
     
    Man-wai Chang to The Door (33600bps), Mar 10, 2010
    #5
  6. Man-wai Chang to The Door (33600bps)

    sean.b Guest

    i know this is an old thread, but i had a stack of these laying aroun
    and i wanted to use them for dynamips, so i figured i'd follow up.

    if you force the windows driver for the Intel Pro/100 S Desktop Adapter
    these cards work. using 4 of them now on windows 7/64 bit
     
    sean.b, Oct 5, 2011
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.