Re: Epson scanner stopped working

Discussion in 'DIY Computers' started by Johnny B Good, Mar 30, 2010.

  1. The message <>
    from Geoff Bayes <> contains these words:

    > Epson DX7450
    > Windows Vista, Service Pack 2


    > This combined printer/copier/scanner was installed in June 2008 and
    > has worked fine ever since, although the scanner is used only
    > infrequently.


    > A couple of days ago I tried to open Scan Assist, the Epson scanner
    > utility, and received an error message saying that it could not start.
    > The Microsoft Paint program and Corel's Paint Shop Pro X both stated
    > that the system had no scanners attached.


    > So I unplugged the Epson, rebooted the computer, ran all the Epson
    > uninstall routines I could find, ran Control Panel\Programs and
    > Features and uninstalled anything with Epson in it and searched the
    > drives for anything relating to Epson and deleted it. I did NOT touch
    > the registry.
    > Then I used the Epson installation CD (Custom Install) to install
    > Epson Scan, Epson Printer Driver, Epson Easy Printing Module and Epson
    > Copy Utility.
    > It now printed, it copied, but it still did not scan.


    > I uninstalled everything again but this time I went through the
    > registry. Anything relating to Epson was deleted until I came to
    > several entries which would not delete. The first one was:


    > HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\STORAGE\Volume\1&19f7e59c&0&_??_USBSTOR#Disk&Ven_EPSON&Prod_Stylus_Storage&Rev_1.00#7&1eb51db9&0&4C34303036479F9269&0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}


    > which pointed to:


    > "Capabilities"=dword:000000a0
    > "HardwareID"=hex(7):53,00,54,00,4f,00,52,00,41,00,47,00,45,00,5c,00,56,00,6f,\
    > 00,6c,00,75,00,6d,00,65,00,00,00,00,00
    > "ClassGUID"="{71a27cdd-812a-11d0-bec7-08002be2092f}"
    > "Driver"="{71a27cdd-812a-11d0-bec7-08002be2092f}\\0005"
    > "Class"="Volume"
    > "Mfg"="@volume.inf,%msft%;Microsoft"
    > "Service"="volsnap"
    > "DeviceDesc"="@volume.inf,%storage\\volume.devicedesc%;Generic volume"
    > "ConfigFlags"=dword:00000000


    > Now I'm lost. I'm _guessing_ that these entries are corrupt and that
    > their presence is preventing a clean re-install, but I don't know. And
    > I don't know how to fix it.


    > I've installed just the printer software and drivers this time. It
    > prints fine and it copies as well. This computer dual-boots with
    > Ubuntu 9.10 and after a bit of fiddling (because I've never tried to
    > scan anything in Linux) the scanner works fine there. But I really
    > could do with it working in Windows, so any ideas?


    Probably a screw up with the USB interfaces. You could try uninstalling
    _everything_ under the USB section in device manager and let windows
    re-install them all on next reboot.

    This has often solved usb related problems in many such similar
    situations. Oh, and when you re-install that Epson MFC device, don't
    plug it in until _after_ all the drivers, particularly the scanner
    related ones, have been installed. This seems a common requirement when
    it comes to image capture devices of any sort that use that bodge of an
    interface we call USB.

    HTH

    --
    Regards, John.

    Please remove the "ohggcyht" before replying.
    The address has been munged to reject Spam-bots.
     
    Johnny B Good, Mar 30, 2010
    #1
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Brian
    Replies:
    7
    Views:
    664
    Brian Innes
    Jul 3, 2004
  2. Johno

    What scanner is like my old Epson 1250?

    Johno, Jul 20, 2007, in forum: DIY Computers
    Replies:
    0
    Views:
    301
    Johno
    Jul 20, 2007
  3. Ian Pollard

    Epson Perfection Scanner

    Ian Pollard, Mar 5, 2008, in forum: DIY Computers
    Replies:
    3
    Views:
    646
    Michael Swift
    Mar 5, 2008
  4. Dan
    Replies:
    0
    Views:
    345
  5. Dan
    Replies:
    1
    Views:
    391
    Damien McBain
    Jan 27, 2004
Loading...

Share This Page