Internet Explorer 8

Discussion in 'Software' started by macrobt, Jun 14, 2009.

  1. macrobt

    macrobt

    Joined:
    Nov 17, 2008
    Messages:
    16
    Location:
    Detroit area
    Hi having trouble with IE8- Event code ID is 1000 , Source is Application Error

    Faulting application iexplore.exe . version 8.0.6001.18702, faulting module mshtml.dll version 8.0.6001.18783, fault address 0x00209d7c

    Anyone have any idea how to correct? IE wont open properly and "needs to close"
    I notice nothing about iexplore.exe in Task manager
     
    macrobt, Jun 14, 2009
    #1
    1. Advertisements

  2. macrobt

    Goober THQ's Jester Moderator

    Joined:
    Jul 26, 2004
    Messages:
    2,864
    Location:
    Colorado
    You could try a few things in internet optionss:
    Open up the control panel and select internet options

    Under the advance tab you can reset IE to default settings
    Under programs you can disable addons

    Another option you could try is to reinstall IE 8
     
    Goober, Jun 16, 2009
    #2
    1. Advertisements

  3. macrobt

    Ian Administrator

    Joined:
    Mar 27, 2008
    Messages:
    650
    Which OS are you using, and I'd try disabling all addons/plugins like Goober suggested.

    Re-installing IE often fixes most things like this, so that's a good option too :)
     
    Ian, Jun 16, 2009
    #3
  4. macrobt

    macrobt

    Joined:
    Nov 17, 2008
    Messages:
    16
    Location:
    Detroit area
    Thanks- tried that. Also Windows Live Messenger doesn't work properly
    O/S is Win XP Home.
    This is error message:

    Source: Application Error
    Event ID 1000

    Faulting application iexplore.exe
    version 8.0.6001.18702,faulting module mshtml.dll version 8.0.6001.18783.fault address 0x00209d79
     
    macrobt, Jun 16, 2009
    #4
  5. macrobt

    Core in pounce mode Moderator

    Joined:
    Jun 30, 2003
    Messages:
    1,556
    Location:
    Akaa, Finland
    Mshmtl.dll (Microsoft HTML Viewer) problems are not limited to IE; they can be experienced with any software product that uses that library, ie Outlook, Live Messenger, etc.

    I'd recommend trying to replace it.

    When I did a fresh install of Windows 7 RC1, I couldn't launch IE8 at all without it crashing. This was after clean install without any extra software installed. I don't remember whether it was related to mshtml.dll because I'm so used to IE crashing on me that I don't much pay attention to it, but I can tell you that I haven't had any issues with IE8 since I switched to a newer build of the RC1, the 7137, which, I believe, also comes with an updated version of IE8.

    My point here is that I think you might be able to simply replace the mshtml.dll with a newer one, in case it's old and/or corrupt.

    My mshtml.dll is of version 8.0.7137. Depending on your OS you may have two of them. If you're using a 32-bit it's probably just the one in Windows\System32. Check the file's properties for version number although I'm pretty sure it's that 8.0.6001.18783 shown in your error message.

    Make sure you have all patches installed from Microsoft Update.

    Run REGSVR32 Mshtml.dll via console in Windows\System32 just to be sure.

    Mainly, replace the mshtml.dll with either another of the same version or, if compatible with your OS, an updated one.
     
    Core, Jun 16, 2009
    #5
  6. macrobt

    macrobt

    Joined:
    Nov 17, 2008
    Messages:
    16
    Location:
    Detroit area
    Thanks Core- I ran command.> REGSVR32 Mshtml.dll and got message-"Mshtml.dll was loaded, but the DLLRegisterServer entry point was not found. This file cannot be registered. Is that what I shouild get?

    I also am having difficulty locating a replacement file-I searched MS and couldn't find file to download- Is this OK http://www.dll-files.com/dllindex/dll-files.shtml?mshtml

    Thanks for help Core-frustrating problem:?
     
    macrobt, Jun 17, 2009
    #6
  7. macrobt

    macrobt

    Joined:
    Nov 17, 2008
    Messages:
    16
    Location:
    Detroit area
    Thanks Core-Replaced Mshtml.dll file and ran REGSVR32 Mshtml.dll and it was successful.
    Long and short of it, back in business. I noticed my event log showed Microsoft IE8 Update on date everything went downhill. I wonder if that had anything to do about problem, as I just noticed same update wants to install??? please let me know your thoughts.:)
     
    Last edited: Jun 17, 2009
    macrobt, Jun 17, 2009
    #7
  8. macrobt

    Core in pounce mode Moderator

    Joined:
    Jun 30, 2003
    Messages:
    1,556
    Location:
    Akaa, Finland
    Normally I run all patches WU has available but if I used IE8 I wouldn't install that one. I've heard of a lot of people having had problems with IE8 after applying that patch. As always, YMMV.
     
    Core, Jun 17, 2009
    #8
  9. macrobt

    Maurice Bloody good bloke VIP Member

    Joined:
    Jun 25, 2009
    Messages:
    352
    Location:
    London England
    Hi, when you go to one of these site switch IE8 into 'compatability' mode and the site should hopefully display correctly.

    I too have noticed on some vBulletin sites that IE8 doesn't display 100% correctly but by adding that site's URL to the compatability mode list generally sorts the problem.
     
    Maurice, Jul 13, 2009
    #9
  10. macrobt

    dylangle3

    Joined:
    Jul 25, 2009
    Messages:
    10
    try reinstalling it.
    I also had same problem but was removed on my second installation.
    I dont know what happened but I just fixed the issue.
     
    dylangle3, Aug 5, 2009
    #10
  11. macrobt

    dylangle3

    Joined:
    Jul 25, 2009
    Messages:
    10
    I got the same error again in one of my pc. trying my above solution was not successful on this one. but here is what fixed it.

    I uninstalled my ie8, and made windows update but this time no ie8 included. I let it install all then made another windows update this time ie8 is my purpose then let it install.

    that fixed my issue.
     
    dylangle3, Aug 15, 2009
    #11
    Core likes this.
  12. macrobt

    Core in pounce mode Moderator

    Joined:
    Jun 30, 2003
    Messages:
    1,556
    Location:
    Akaa, Finland
    Very interesting.

    Thank you for posting and letting us know how you fixed the issue. This is immensely useful for other people who come across the same problem in the future.
     
    Core, Aug 15, 2009
    #12
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. quaium

    Internet Explorer 6 won't load Jave Applets

    quaium, Dec 22, 2003, in forum: Networking and Internet
    Replies:
    6
    Views:
    1,010
    James
    Dec 22, 2003
  2. sheepy567

    Internet Explorer wont start

    sheepy567, Jan 31, 2004, in forum: Networking and Internet
    Replies:
    1
    Views:
    696
    James
    Jan 31, 2004
  3. Arckturis

    Internet Explorer Problem

    Arckturis, Mar 19, 2004, in forum: Networking and Internet
    Replies:
    10
    Views:
    1,072
    James
    Mar 26, 2004
  4. Kristi
    Replies:
    0
    Views:
    2,420
    Kristi
    Mar 28, 2004
  5. Rob
    Replies:
    3
    Views:
    467
Loading...

Share This Page